THE SITE WAS REDONE SOME MEMBERS WHERE LOST IF YOU CAN'T LOG IN MOST LIKELY YOU HAVE TO RE REGISTER SORRY
Results 1 to 4 of 4

Thread: check engine light

  1. #1
    Join Date
    Apr 2016
    Posts
    5
    Thanks
    0
    Thanked 3 Times in 3 Posts

    Default check engine light

    wasnt sure where to put this one , but.... check engine light comes on when the RPM's get up around shifting range . when i let off the gas to shift , or just let off the gas , the light goes out . it comes back on when the RPM's go back up . thinking vacume leak ? it runs fine just trying to figure out why it would do that . i just put in a new computer and it runs great .

  2. #2
    Join Date
    Jan 2010
    Location
    New Bedford MA
    Posts
    475
    Thanks
    45
    Thanked 50 Times in 35 Posts

    Default

    i would first check back of the dash clean connectors and dielectric grease them glad pc fixed it sounded like it was ignition module inside it

  3. #3
    Join Date
    Apr 2016
    Posts
    5
    Thanks
    0
    Thanked 3 Times in 3 Posts

    Default

    it was an easy fix , pulled the bulb

  4. The Following User Says Thank You to jdn40 For This Useful Post:

    Mastertek2000 (04-23-2016)

  5. #4
    Join Date
    Apr 2016
    Posts
    5
    Thanks
    0
    Thanked 3 Times in 3 Posts

    Default

    Quote Originally Posted by Mastertek2000 View Post
    i would first check back of the dash clean connectors and dielectric grease them glad pc fixed it sounded like it was ignition module inside it
    already did that . im also having a problem with the speedometer . it stopped working some time back . i replaced the housing , speedo head and the sensor and even the gear . was hoping the computer would fix it but no luck . not sure where else to look . also the ribbon in the housing looks fine . all other lights and tach work .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •